logo nvidia

Los últimos controladores de Nvidia fallan en Plasma

Martin Gräßlin, desarrollador de Kwin, ha detectado un fallo en la versión 384 de los controladores de Nvidia para Linux que provoca un fallo grave en Plasma.

Así que la recomendación es que no actualices tus controladores. Si ya lo has hecho y usas el escritorio de KDE, deberías volver a una versión anterior. Los programas afectados por el bug son KWin y KScreenLocker, por lo que con los drivers defectuosos no es posible bloquear la sesión y KWin se puede cerrar.

Los que por cualquier razón queráis continuar con la última versión, podéis forzar QtQuick a que use el modo “raster” en vez del “gl”, con la consiguiente pérdida de rendimiento. Para ello tan solo hay que modificar la siguiente variable de entorno:

export QMLSCENE_DEVICE=softwarecontext

En realidad, los controladores 384 para Linux venían con algunas cosas que pueden obligar a algunos (no muchos) a usarlos. Recordando los cambios con respecto a la anterior versión, estos trajeron soporte para Max-Q Design para los modelos GTX 1060 / 1070 / 1080 móviles. Max-Q Design son chips gráficos destinados a portátiles finos y silenciosos. Además se añadió soporte a la GT 1030, la MX150 y la P106-100 (lo que viene siendo el acelerador Tesla V100 Volta). También se solucionaron algunos fallos en OpenGL, la aceleración de video por hardware VDPAU y otros de menor relevancia.

Así que si eres Kdeero y tienes todo el software a la última, tienes que elegir entre controlador antiguos + rendimiento o controladores actuales + pérdida de rendimiento.

Vía el blog de Gräßlin.

Ver comentarios